Utilisation des fonctions dans un tableur
Retour au menu : Accueil - Index général - L'ordinateur dans le shack


Voir aussi : Utilisation élémentaire d'un tableur - Calculs simples à l'aide d'un tableur - Application du tableur : formule de Thomson - Notion de fonction -

Qu'est-ce qu'une fonction

Pour faire simple, on peut comparer une fonction à une moulinette : on lui donne un steack, on tourne la manivelle et on récupère un steack haché. Une fonction simple est la fonction sinus. Appelons y le résultat escompté (le sinus) et x l'angle en radian dont on veut calculer le sinus. On écrira :
y=sin(x)
Dans le tableur, on a mis la valeur de l'angle en radian dans la cellule B2 et la formule dans la cellule B3. On voit en (1) que la formule à entrer est très simple.
Question : quelle est la formule qui a été entrée en C3 ?
Réponse : =SIN(C2)

Saisie du code de la fonction dans une formule

Il n'est pas nécessaire de connaître ni de saisir le code de la fonction désirée. Il suffit de la sélectionner dans une liste. Pour cela :
- sélectionner la cellule où l'on veut saisir la fonction (2)
- cliquer sur le bouton (1), la boîte de dialogue "AutoPilote..." apparaît.
- dans la liste (3), sélectionner la famille de fonctions désirées.
- double-cliquer sur la fonction désirée (ici logarithme décimal), la formule s'inscrit dans la zone de saisie "Formule" (non visible sur la figure)
- cliquer sur la cellule contenant le nombre (ici B2)
- cliquer sur OK

Liste des codes de fonction les plus courants

La syntaxe des fonctions est assez facile à retenir. En voici une liste des plus utilisées en radio.
 résultat à obtenir  syntaxe dans StarCalc
 nombre pi  =PI()

 somme des nombres d'un groupe de cellules

 =SOMME(A1:A6)

 racine carrée de A1

 =RACINE(A1)

 logarithme décimal de A1

 =LOG10(A1)

 sinus de l'angle A1 exprimé en radians

 =SIN(A1)
 sinus de l'angle A1 exprimé en degrés  =SIN(B9/57.3)
 cosinus de A1 en radians  =COS(A1)
 tangente de A1 en radians  =TAN(A1)
 conversion en radians de l'angle A1 en degrés  =RADIANS(A1)
 conversion en degrés de l'angle A1 en radians  =DEGRES(A1)
 carré de A1 (les arguments sont séparés par ; )  =PUISSANCE(A1;2)
 racine cubique (1/3) de A1  =PUISSANCE(A1;1/3)

Autres fonctions

Il existe de nombreuses autres fonctions qui permettent de construire des applications de gestion ou de calcul très élaborées. En voici quelques exemples.
 résultat à obtenir  syntaxe dans StarCalc
 afficher la date du jour dans une cellule  =AUJOURDHUI()
 affiche la date du jour et l'heure  =MAINTENANT()
 donne le nombre de caractères de la phrase en A1  =NBCAR(A1)
 renvoie les 5 caractères de la phrase A1 à partir du deuxième caractère de la phrase.  =STXT(A1;2;5)
 affiche le mot contenu dans le deuxième argument si la condition du premier argument est remplie, sinon c'est le troisième argument qui s'affichera.  =SI(A1>0;"positif";"négatif")
 renvoie la valeur logique VRAI si A1 est vide  =ESTVIDE(A1)
 recherche dans la première colonne de la table A2:B12 la valeur contenue dans A1 et renvoie la valeur placée sur la même ligne dans la colonne 2  =RECHERCHEV(A1;A2:B12;2;1)


Formules plus complexes

Une fonction peut en utiliser une autre en tant qu'argument. Par exemple le logarithme décimal du sinus de 30 degrés va se calculer avec :
=LOG10(SIN(RADIANS(30)))
Les erreurs de syntaxe sont signalées par le tableur, par contre les erreurs de raisonnement sont parfois difficiles à détecter. Il est prudent de décomposer les calculs en vérifiant à la main les résultats intermédiaires. Par exemple, pour la formule ci-dessus :
- On sait que 30 degrés égalent un demi-radian, on tapera donc la formule =RADIANS(30) pour effectuer le calcul. Le résultat affiché donne 0,52 ce qui est correct.
- Le sinus de 30 degrés est égal à 0,5. Tapons la formule suivante pour le vérifier =SIN(RADIANS(30))
- Nous ne connaissons pas le log décimal de 0,5 : commençons par le calculer en entrant dans une autre cellule =LOG10(0.5) le résultat est 0,3 En remplaçant 0.5 par le calcul du sinus précédent on pourra vérifier que la formule complète fonctionne parfaitement =LOG10(SIN(RADIANS(30)))
Attention à l'utilisation des parenthèses pour hiérarchiser les calculs. Voir Calculs simples à l'aide d'un tableur.